CRAN Package Check Results for Package permGPU

Last updated on 2021-10-21 07:50:04 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.15 7.41 70.28 77.69 WARN --install=fake --no-examples --no-tests --no-vignettes
r-devel-linux-x86_64-debian-gcc 0.15 7.37 55.33 62.70 WARN --install=fake --no-examples --no-tests --no-vignettes
r-patched-linux-x86_64 0.15 8.53 70.65 79.18 WARN --no-examples --no-tests --no-vignettes
r-release-linux-x86_64 0.15 9.30 70.26 79.56 WARN --no-examples --no-tests --no-vignettes
r-release-macos-arm64 0.15 ERROR
r-release-macos-x86_64 0.15 ERROR
r-oldrel-macos-x86_64 0.15 ERROR

Check Details

Version: 0.15
Flags: --install=fake --no-examples --no-tests --no-vignettes
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:18: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:18: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     ./lib/autoconf/general.m4:1553: AC_ARG_WITH is expanded from...
     configure.ac:18: the top level
     configure.ac:47: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:47: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     ./lib/autoconf/general.m4:1553: AC_ARG_WITH is expanded from...
     configure.ac:47: the top level
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc

Version: 0.15
Flags: --no-examples --no-tests --no-vignettes
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:18: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:18: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     ./lib/autoconf/general.m4:1553: AC_ARG_WITH is expanded from...
     configure.ac:18: the top level
     configure.ac:47: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:47: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     ./lib/autoconf/general.m4:1553: AC_ARG_WITH is expanded from...
     configure.ac:47: the top level
Flavors: r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.15
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavors: r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64